icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.bdkyy.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

彩票数据分析软件 www.048658.com-辽宁3d水果图彩吧| www.533779.com-3d彩票怎么推算| www.296166.com-国家整顿重庆时时彩| www.539280.com-彩票能伪造吗| www.715028.com-五分彩有什么规律| www.211933.com-手机购彩软件哪个好| www.84863.com-福彩彩乐乐-| www.079057.com-彩8计划助手| www.31214.com-彩票走势图易网| www.703156.com-湖南省福利彩票网| www.286166.com-中国河南福彩快三| www.222727.cc-安徽福彩网官网| www.322579.com-南通竞彩-| www.409995.com-鸿运彩票如何| www.581102.com-足彩任九场投注秘诀| www.673917.com-和玺彩绘-| www.761872.com-波彩之家-| www.856678.com-白菜派彩网-| www.928535.com-福清诞生彩票巨奖| www.982202.com-上海福彩网下载软件| www.fj7.cc-新时时彩下载| www.ob62.com-海南福彩-| www.q09.site-菲律宾正规彩票| www.42vt.com-任九新浪爱彩| www.535565.com-属龙购买什么彩票| www.550538.com-天天彩票快3| www.092464.com-9号彩票捷豹平台| www.506508.com-竟彩蓝球258| www.655457.com-福利彩票中奖神器| www.cu59.com-私彩平台哪个可靠| www.640048.com-pc福彩-| www.74849.com-中彩网首页官网预| www.365.shop-我爱彩票注册| www.1085.net-彩69收米-| www.444713.com-彩票为什么不实名| www.895415.com-严玉进华彩-| www.192737.com-江西福彩双色球开奖| www.283151.com-新加坡华乐彩票| www.365932.cc-国产水溶彩铅哪种好| www.097187.com-福彩小鱼图反正面| www.7709.pw-168官方彩票网站| www.837396.com-巨彩平台-| www.920120.com-赢彩计划软件安卓版| www.983524.com-彩933-| www.im6.cc-内蒙古新快三| www.rp58.com-体彩10分钟-| www.456042.com-手机刮奖彩票| www.303132.com-好彩2复式计算器| www.83240.com-安阳有转让彩票站| www.918830.com-彩票外围-| www.29666.cc-中国体彩网七星彩| www.026043.com-手机淘宝能买彩票吗| www.153856.com-彩票平台注册送38| www.390717.com-南方七星彩源码| www.528408.com-彩票单式和复式区别| www.618192.com-江苏快三开奖好吗| www.712197.com-e乐彩入口-| www.795675.com-彩票试机号今天3d| www.884698.com-鳄鱼彩票猪八戒| www.997793.com-彩票天天乐下载| www.hc51.com-测彩密招-| www.04hd.com-彩票快三如何稳赢| www.9981.tv-福彩3d组选走势| www.751370.com-金六福彩票-| www.858247.com-彩票是个无底洞| www.931026.com-体彩七星彩如何中奖| www.997293.com-时时彩彩八仙手机版| www.ap05.com-福彩3d布衣图2| www.7260.loan-彩虹3b无人机售价| www.056966.com-七星彩怎么才算中奖| www.350448.com-陕西福彩十分开奖| www.245637.com-搜索中国竞彩网| www.308098.com-甘肃福利彩票七乐彩| www.082219.com-澳洲赛车彩票网站| www.c7.gg-北京福彩快三| www.33357.cc-东南快三查询| www.812555.com-福彩3d胆码解码书| www.55770.com-七乐彩是那年开始| www.1226.com-彩计划app登录| www.46788.com-体彩七位数中奖图片| www.60277.cc-500万彩网-| www.616209.com-体彩服务号-| www.207483.com-快三彩票qq交流群| www.90429.com-福利彩票自选怎么买| www.035294.com-字彩票用语-| www.185563.com-体育彩票发行宗旨| www.276857.com-盈彩网买彩票合法吗| www.328058.com-手机58彩票app| www.vj58.com-今日开奖快三河北| www.29.la-足彩胜负彩中奖规则| www.813405.com-福利彩票3d价格| www.700709.com-彩票可以跨店兑奖| www.8452.top-博友彩是怎么运行的| www.302414.com-快三走势图北京的| www.393992.com-福彩昨天出奖号| www.58003.com-家彩网预测-| www.033092.com-炫乐彩票标准版| www.396703.com-我想福利彩票| www.592525.com-一点通彩吧图库| www.db64.cc-彩神大发是真的吗| www.73922.cc-福州体彩十一选五| www.090983.com-南宁市福彩大厦| www.65ve.com-大同市福彩中心地址| www.2154.xyz-今日福彩三地字谜| www.2738.xyz-黄岩西城福彩网点| www.80538.com-3d双彩网字谜汇总| www.333102.com-查体彩开奖结果查询| www.eg2.cc-快三彩票真的假的| www.392014.com-海南体彩投注软件| www.605600.com-定制手机彩膜图片| www.326200.com-万彩吧c8cn6合| www.ft04.com-买百盈快三的技巧| www.214290.com-秒速时时彩开奖图| www.284555.com-中国福彩彩种介绍| www.349827.com-彩神计划王-| www.404818.com-福利彩票6加1玩法| www.144978.com-众彩网千里马预测| www.227802.com-彩票有假吗-| www.304948.com-七星彩数据库| www.383768.com-时时彩api-| www.493337.com-彩票时间销售截止| www.609047.com-彩票自动下单源码| www.674118.com-古建彩绘视频| www.753932.com-网络彩票坑-| www.849310.com-篮球彩票吧百度贴吧| www.930080.com-863人工彩票计划| www.cc64.com-福彩排列3-| www.xv17.com-好想中彩票-| www.358260.com-黑彩平台能活多久| www.160140.com-竞彩胜平负不开售| www.7113.cc-建盏养出七彩| www.63nr.com-北京昨晚快三走势图| www.779.cm-各大彩票预测软件| www.893.in-彩票33带上岸| www.19591.cc-五分时时彩开奖网址| www.767044.com-福彩三d彩吧论谈| www.863841.com-999彩票网合法吗| www.949165.com-ig彩票平台官方网| www.f56.net-体彩中奖号码查询| www.956034.com-今天双色球彩报字谜| www.4111.xyz-彩虹网络电视下载| www.380798.com-澳门快三是什么彩| www.528322.com-怎么破时时彩的规律| www.636442.com-幼儿绘画彩虹| www.741822.com-彩票天天-| www.830393.com-什么软件可以查彩票| www.909713.com-乐彩33app-| www.998186.com-附近体彩店电话| www.qp68.com-快三号码表图片| www.23pj.cc-高频彩票有人控制| www.62826.cc-体育彩票足球比分| www.856398.com-彩票反买是什么意思| www.917072.com-儿童彩铅画风景图片| www.998647.com-体育彩票7位数开奖| www.hf25.com-易彩网手机版| www.531308.com-彩93彩可靠吗| www.257411.com-红牛彩票官网| www.121621.com-彩票历史开奖查询| www.194636.com-快三买大小单双技巧| www.261292.com-福彩快三豹子守号表| www.522376.com-a9彩票正规吗| www.14491.com-七星彩胆拖怎么玩| www.48345.cc-甘肃竞彩专家推荐号| www.f26.club-福彩在线提现不了|